How to Determine which Xposed Module version You Need




Xposed has been a one of the best apps for tuning a rooted android phone. It does enable many sub tools like enabling soft key buttons and customizing navigation keys functions. Check this guide to know what you could do with xposed.


I know what Xposed is and what does it Do! I'm just a bit confused which version of xposed framework I have to flash in order to activate it? - says a frustrated user.

In this post, we'll explore how to determine which Xposed version you actually need, according to your CPU architecture and android version.

This official xposed download directory doesn't ring a bell about which version is for what use. Or let say xda tends for knowledgeable persons.

Let's know how to Crack this.

First you need to know about your CPU architecture. Consider checking your phone spec online by Google 'your+phone+name specs' and look for CPU architecture.

1. The First thing you need to figure out it what kind of processor your phone have. Major android phones runs on arm processors (normally 32-bit).

If your device is 32-bit use  arm.zip

If your device is ARM 64bit you need arm 64.zip

And if your device is running on x86 use x86.zip

2. Check your android version.


Second things are to know about what android version your phone is having. To know this Go to phone settings - about - Android version. You will see android version listed there. However this is a very simple task, it can happen that you already know it.

You need to choose xposed SDK version according to your phone's android version. This is very important flashing a wrong SDK zip cab cause xposed to not work.

After lollipop, Google made it's android very hard for any app to breach into its system, but developers finally announced a stable version for. Lollipop and Marshmallow.


  • If your phone is running on lollipop 5.0 you need to download xposed sdk21
  • If you have a updated lollipop 5.1.1 you will need to download and flash xposed sdk22.
  • And if you are running on beautiful maverick called marshmallow (android 6.0) you are going to use xposed sdk23


For quick reference.

Android 5 = SDK21
Android 5.1 = SDK22
Android 6.0 = SDK23

Example 1. Now, for example, I have arm CPU and android marshmallow, so I need to download and flash sdk23 arm.zip

Example 2. I have arm CPU and my android version is lollipop 5.0 so I'm going flash sdk21 arm.zip.

Got the point.

Now download the appropriate version, place that inside SD card or internal storage.
Turn on your phone and start entering into recovery mode. If you are on CWM recovery touch to install option then locate the xposed zip module and flash it.

Restart your phone, now install the Xposed UI app for managing it. Click here

Final words.
Xposed is a one of the best kit for rooted phone, now you have easily figured out how to determine CPU architecture and android version. To know which Xposed framework version will work on your side. Always make an apps backup to be on safer edge.

If you believe there is an error in this article contact us. We'll correct it and give you a bounty.

Do you have a question or anything popping in your mind? Consider flashing them in the comment section. However, I mind you asking questions if you're entrepreneur (because they belong here)
How to Determinee which Xposed Module version You need to Flash

Popular posts from this blog

[Cyanogenmod 14 ] CM14 Features and Release Date